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The following changes have been made to DAT/EM products between Release 6.3 and Release 6.4. Please review these 
revisions made to the software and update your software to implement changes. 
 
As always, DAT/EM welcomes comments and suggestions from you, our clients, so please don’t hesitate to contact our 
support department at support@datem.com, or by calling in or faxing us with your requests. 
 
 
Operating Systems 
 
Release 6.4 is supported on Windows XP Professional, VISTA Ultimate and Windows 7 Ultimate or Professional 
operating systems. Testing no longer occurs for Windows 2000. If you have a question, please contact Support. 
 
CAD Versions 
 
Release 6.4 has interfaces to the following 32-bit and 64-bit CAD versions: 

 AutoCAD: Autodesk 2002, 2004, 2005, 2006, 2007, 2008, 2009, 2010, 2011, and 2012 products 
 ArcGIS: ArcMap 9.1, 9.2, 9.3 (service pack 1), 9.3.1(service pack 2) and 10 (service pack 2) 
 MicroStation: MicroStation V8 and V8 2004 Edition, XM, V8i Select Series 1 and Select Series 2, and Bentley Map Select 

Series 1 and Select Series 2 are approved. Select Series 2 is recommended over Series 1. 
o Note for Select Series 1-to-2 upgrades: If you upgrade to MicroStation or Bentley Map from Select Series 1 to 

Select Series 2, you must re-install any DAT/EM software afterwards. The Select Series 2 software does not remove 
existing DAT/EM applications, and they will appear to load correctly. However, the applications installed for Select 
Series 1 may not work well when you use specific commands. Reinstalling the DAT/EM software installs new Select 
Series-2-specific DAT/EM applications. 

 
 

Hardware Locks/Dongles 
 
Please install Microsoft Updates and Service Packs for your operating system before applying lock reset programs. Network licensing 
should have the same Sentinel driver version on both the server and the local computers running the software. 
 
 
SUMMIT EVOLUTION 

 

 
1. Multiple stereo viewports supports images of different scales within the same project. 

a. If Image Scale is set in the Project>Edit dialog, DAT/EM uses this value to set the viewport scale 
adjustment. As long as there is an Interior Orientation, the adjustment will apply in any mode, such as during 
Tie Point measuring, or viewing single images. 

b. If an image does not have an Image Scale (set to 0), then a scale adjustment will only occur when the 
viewport has a ground orientation. 

c. If a project is non-aerial, then ground per pixel (GPP) will be used to set a scale. 
 
2. The DTM file list for Terrain Following is now saved in the project file. 
 
3. Support for the GGS SoftMouse was added. 
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4. Principal point offsets applied to DVP PAR file import projects is now supported. 
 
5. SUMMIT EVOLUTION’s superimposition (SI) was updated to render AutoCAD XREF blocks in the correct location. 

Previously, the XREF blocks were displayed (possibly out of the view), but not in the correct location. 
 

6. Some Socet Set SUP files used for importing projects into SUMMIT EVOLUTION may have zeroes in the 
TRI_PARAMETERS section. SUMMIT EVOLUTION reads this information for orientation. As of Release 6.4, if 
the data is zero SUMMIT EVOLUTION acquires the orientation information from two other options in the SUP file 
and the import is successful. 

 
7. The “Move to Objects” tool icon may now be added to a toolbar from Summit>Tools>Customize 

Toolbars>Command tab>Tools. 
 

8. Si LiDAR Tool: After applying a filter and updating the display, the entire point file would not refresh in the display 
when the filter was removed. This has been fixed. There is an option to “Select All” for viewing all points. 

 
9. Control Transfer has been implemented for use with two instances of SUMMIT EVOLUTION. This allows control 

transfer from one stereo SUMMIT project (fully oriented) to another stereo SUMMIT project (needing orientation) in 
the same geographic area. This option has been added to the existing orthophoto and vector file control transfer 
methods. Select Summit>Orientation>Control Transfer. 
 

 
 
The new SummitEv button will open another instance of SUMMIT whether "Allow multiple instances of SUMMIT" is 
on or off (in Summit>Tools>Options>Project tab). Alternatively, another SUMMIT may be opened by clicking the 
SUMMIT desktop icon or from Windows Start if "Allow multiple instances of Summit" is enabled; be sure to start 
Summit>Orientation>Control Transfer from the instance of SUMMIT that needs to be oriented (not from the one 
that already has ground coordinates). 
 
Position both SUMMIT EVOLUTION windows on the stereo screen so they may be viewed in stereo at the same time. 
 
Use the instructions in the manual for Control Transfer with Orthophoto, but instead of an orthophoto in IMAGE 

VIEWER, use the second instance of SUMMIT. Control Transfer as a process does not do anything new, except for 
allowing measurements to be recorded in ground units from a second instance of SUMMIT (in stereo), just like it 
does with the “Orthophoto” option. 
 
When using Control Transfer, you may automatically transfer the 3D input device control between instances of 
SUMMIT. For a SUMMIT window to gain control of the input device, simply click on it with the system mouse (or use 
other Windows methods to give the desired window focus, such as <Ctrl><Tab>). The 3D mouse control is 
automatically transferred when you give focus to the SUMMIT window. The 3D device will stay with this SUMMIT 
until the other SUMMIT gains focus. This ability is enabled any time two SUMMITs are open, whether Control 
Transfer is running or not. (NOTE: this only works with two SUMMITs, if you open more SUMMITs, this will cease to 
function.) 
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10. There is now an Exterior Angle button in the Tie Points dialog which rotates images according to their exterior 

angles. The angles remain active until the button is de-activated by selecting it again. All other manual angle 
adjustments are inactive until the Exterior Angle option is off. Use the Exterior Move button to switch to ground 
movement mode. Any measurements made while the Exterior Move mode is active ignore any locking constrains 
that would normally be in effect. 

 

 
 
The ability to move using Exterior Angles may be useful for projects containing oddly shaped flightlines across 
areas with high elevation changes. Previously, it was not possible to measure in Relative mode from the Tie 
Points dialog and six points were required before the Relative mode could be viewed. 
 

11. This is now a "Side by Side" checkbox in all Tie point type dialogs, including: Relative Orientation, Tie Points, 
Satellite Tie Points, and Photo Stitch Tie Points (see Photo Stitch in 13. below). Side by Side mode is used the 
same way in all of these dialogs. When “Side by Side” is off, measurement is done in one stereo view. When it is 
on, two views show the right and left images separately. The clutch button toggles whether the images move 
together or separately, and are subject to the usual rules of image locking depending on which image has an 
existing measurement. Align the cursor on the same feature in both images and digitize. Toggle the mode at any 
time. 

 

 
Example of Side by Side mode on for tie points in an aerial project 
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12. There is a new “Add Multiple” button for Satellite RPC projects. Select a directory and all images and RPC files 

will be combined and added to the project. In addition to using this option, you may drag and drop images into the 
Project Edit dialog from Windows Explorer. The matching RPC files will automatically be attached. 

 
13.  “Photo Stitch” is a new project type that can make one composite image out of two or more smaller, overlapping 

images. Although there are other commercial products to do this, they typically have three problems: They require 
loading all the images into memory (which could crash the computer), they require large overlaps, and they do not 
offer manual tie point measurement. DAT/EM’s version solves all of these problems. Photo Stitch was designed to 
combine historical CORONA satellite images in preparation for building a CORONA project, which will be offered 
in a future release of DAT/EM software. Photo Stitch may also be used with any other overlapping images, such 
as from a handheld digital camera. To use Photo Stitch, perform the following steps: 

 
a) Select Summit>File>New Project>Photo Stitch. 

 

 
 

b) Either use “Add” or drag and drop all the adjoining images into the dialog. Add only those images that 
make up one output image. Images for stereo pairs should be processed separately (start a new Photo 
Stitch project for each output image). Use “OK” to close the dialog, then use Summit>File>Save or Save 
As to name the project. 

 
c) Use Summit>Orientation>Tie Points to measure a minimum of five (5) tie points along the adjoining 

edges of each set of overlapping images. 
 

 
Notice that this Tie Points dialog is unique to the Photo Stitch project type; 
The residuals are in pixel units and it has a Stitch button at the lower left. 
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If desired, check on the Side by Side setting. This changes the tie point measurement display from 
stereo to a mono side-by-side display for individual left and right image positioning. There is no set 
recommendation for using Side by Side; it depends on the user’s preference and the particular project. 
 

 
Example of a side-by-side tie points display. The alternative is a stereo display. 

 
 
d) Select the Stitch button. Choose settings such as optional JPEG compression, the output file name, and 

the feather distance (in pixels) for color blending at the edges of the images. 
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Example of stitched digital handheld camera photos: 

 

 
 

Example of Photo Stitch results for historical CORONA satellite imagery (note that the CORONA 
satellite project type is not yet available): 
 

 
 

 
14. SUMMIT EVOLUTION now offers its own satellite projects with optional image epipolarization for stereo imagery from 

the following satellites: JAXA ALOS “DAICHI”; GeoEye® IKONOS® and GeoEye-1; DigitalGlobe® QuickBird, 
WorldView-1, and WorldView-2; Satellite Imaging Corporation SPOT-5. Of these, the SPOT-5 project is 
considered a beta, due to the low number of test projects available at DAT/EM. If you have SPOT-5 stereo 
imagery, consider sharing it with DAT/EM to help in the development and verification of this project type. 

 
If you wish to create one of these projects, please ask support@datem.com to send you detailed documentation. 
In general, these projects share the same general procedure: 
 

Step 1. If a control file will be used for either measurement or for “Move to Ground”, create a .con file 
expressed in the final target coordinate system. 

 
Step 2. Use IMAGE CREATION to make the zoom levels for each image. Exception: ALOS projects may 

either create zoom levels now or create them automatically in step c., if desired. 
 
Step 3. Start a new project. Select ALOS 1 for ALOS “DAICHI” imagery, select SPOT 5 for SPOT-5 

imagery, and select Satellites with RPC for IKONOS, GeoEye-1, QuickBird, WorldView-1, and 
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WorldView-2 imagery. Define the data as requested in the resulting project dialogs. Set the final 
target coordinate system. 

 

 
 

Step 4. Create models using the manual “+” method of matching models (automatic model creation for 
satellite projects will be added in the next release). 

 
Step 5. Open each model in turn and use Tie Points to measure relative and control points (if any). 

Measuring control points is recommended whenever possible. Even one or two good control 
points can greatly improve the ground adjustment for the model. 

 
Step 6. View the resulting stereo imagery after Tie Points is finished. If stereo is very good and objects 

are scaled and rotated the same, then the imagery is already epipolarized; use this project as-is 
and stop here. 

 
Step 7. (If epipolarization is needed) If objects in the left and right images appear to be rotated with 

respect to each other and/or scaled differently, select Summit>Imagery>Satellite Epipolar. 
Input the current project. To avoid wasting time generating a full project with the wrong settings, 
DAT/EM recommends that you first set Image Level=16X as a quick test; this makes a low-
resolution test project based on one of the zoom levels and will be very fast; view the results for 
general appearance and scaling; if you think these settings will work, return to 
Summit>Imagery>Satellite Epipolar and set Image Level=1X and run the full project based on 
the 1X image. If you don’t like the 16X results, you may try a different Epipolar Technique (with 
16X first) or measuring more tie and/or control points; try another 16X test before using the full 
1X. Open the epipolarized project. 

 
 



DAT/EM Systems International RELEASE 6.4 Product Notes 

 8

15. POINT TRANSLATOR has the following changes: 

a) It has a new save and open settings options. The save icon at the lower edge of the dialog saves a .reg 
file, which may be loaded again later using the open icon. The file may be opened by POINT TRANSLATOR 
on any workstation that has the same version of DAT/EM software installed. 

b) Additional point files supported in POINT TRANSLATOR and all other DAT/EM tools that read point files 
include Leica’s .PTS point file format and TIFF DTM. 

 

16. IMAGE CREATOR has the following changes: 

a. Tiny pieces of images in satellite projects using .TIL files were not processed for zoom pyramids. This was 
fixed. 

b. The IMAGE CREATOR has some caching improvements that will allow it to run approximately 10 times faster. 
 

17. PROJECT VIEWER WITH ORTHOPHOTO AND MOSAIC has the following changes: 
 

a) A change was made to how the zoom level of the input files is selected when generating orthophotos. 
This prevents jagged-looking results where previously one zoom level was used from one input image 
and another zoom level was used from the next input image. This would only happen when the resolution 
of the generated orthophoto was at the boundary between zoom levels in the input files. 

 
b) A problem has been fixed in the hotspot removal process. The problem could make some orthophoto 

pixels the same color as the background or true ortho color when hotspot removal was applied. This 
would appear as speckling or spotting. This was more likely to happen if the background or true ortho 
colors were pure black (0,0,0) or pure white (255, 255, 255). 

 
c) When channel mapping was on, 4-band images would be made into 3-band orthophotos. This was 

corrected to output 4-band orthophotos. 
 

 
 
 
 
LANDSCAPE 
 

 
 

1. After manually editing selected points, an UNDO was not refreshing the point display properly. This was fixed. 
 

2. Support for the GGS SoftMouse digitizing device was added. 
 

3. Additional point files supported in DAT/EM products include Leica’s .PTS point file format and TIFF DTM. 
 

4. DAT/EM Drawing Tools have added vertex editing, object dragging ability, and improved line offsetting and spot 
height support. 
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5. There is a new method of interactive breakline editing with faceshift ability. This option shifts the points within the 
boundary to match a TIN made from the breakline and surrounding surface. To use: 

 
Step 1. Preparation: Open a project and load points. Load a vector file using the Drawing Tools. Prepare 

a layer for breakline vector objects. 
Step 2. Interactive point editing may be done using either LANDSCAPE or SUMMIT EVOLUTION to control the 

cursor. If using SUMMIT EVOLUTION, activate Control Cursor with Summit. 
Step 3. Activate Edit Tools>Interactive Point Edit.  
Step 4. Select Edit Tools>Breaklines or select Edit Points around Lines from the Point Edit toolbar. 
 

 
Step 5. Make settings: 

 Horizontal Distance modifies points within this xy distance of either side of the 
polyline vectors. 

 Vertical Tolerance does not modify points if they are within this z distance of the 
polyline vectors. If this value is 0 (zero), the vertical tolerance is ignored. 

 Delete removes the points. 
 Shift Points moves the points to the elevation of the polyline vectors. 
 Change Class changes the points to the New Class selection. 
 Shift Points and Change Class moves the points to the elevation of the polyline 

vectors and changes their class to the New Class selection. 
 

Step 6. Set the layer for the breakline. 
Step 7. Select a drawing tool (for example, point to point or polyline squaring) from LANDSCAPE’s Drawing 

Tools toolbar. 
Step 8. Draw the polyline. When the polyline is finished, the points will be deleted, moved, and/or 

changed, depending on the settings. 
 

 
 



DAT/EM Systems International RELEASE 6.4 Product Notes 

 10

 
6. More than one orthophoto may now be added to the project. An Image Manager has been added to help show the 

list of orthophotos. Turn on the Image Manager from Landscape>Windows>Image Manager or from “View 
Image Manager” on the Windows toolbar. It may either be undocked or docked to the main LANDSCAPE window. 
Use the browse button to add an image to the project. To delete an image, click on it to highlight it and select the 
“X” button. 

 

 
  

7. The LIDAR Filter Editor has a new option to “Add default class filters”. This adds a list of default filters to the 
“Filter Names” list. (This applies to the LIDAR Filter Editor launched from any DAT/EM application, such as 
SUMMIT EVOLUTION, LANDSCAPE, and POINT TRANSLATOR.) 
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DAT/EM CAPTURE for ArcGIS 

 
NOTE: Compatible with 32-bit versions of ArcGIS 9.1, 9.2, 9.3.1, and 10 (each with the latest service packs installed) 
 

1. Superimposition was improved as follows: 
a. It can now handle Bezier curve objects. These complex objects required using a curvature check call that 

was taking a long time to complete. 
b. It was displaying subtypes in the SUMMIT EVOLUTION view when the layer was unchecked (off) in the 

ArcMap Table of Contents. Subtypes will no longer display unless they are checked on. 
 

2. When a layer has classifications according to data in one of its fields, SI would always display the objects, even if 
they were turned off on the ArcMap side. This was fixed. 

 
3. ASCII Import has the following improvements: 

 
a. It no longer offers checkboxes for fields that should not be changed by the user, such as ObjectID. It now 

offers only those fields that are acceptable to populate with data from the input file. 
b. If importing to a polyline layer and there is no “Object Group” field in the input file, one polyline will be 

created from all of the coordinates in the file. Previously, it would fail to place anything or it would place 
them at zero coordinates. 

 
 

 
DAT/EM CAPTURE for AutoCAD 

 
 
NOTE: Compatible with 32-bit AutoCAD 2000-2012 versions with the latest service packs. 
 Compatible with 64-bit AutoCAD 2008-2012 versions with the latest service packs. 
 

1. In AutoCAD 2010 and higher, Capt2D streaming was slow due to SUMMIT EVOLUTION’s SuperImposition 
completely redrawing each time a point was added. This has been fixed and performance has improved. 

 
2. DatDraw Stream digitizing mode performance has improved. 

 
3. SUMMIT EVOLUTION’s superimposition (SI) was updated to render XREF blocks in the correct location. Previously, 

the XREF blocks were displayed (possibly out of the view), but not in the correct location. 
 

4. DTMDistributor’s .sdtm (“Summit DTM”) output format was not being written correctly. This would cause problems 
when the file was subsequently used as input in other DAT/EM applications, such as SUMMIT EVOLUTION or 
LANDSCAPE. This has been fixed. 

 
5. Labelit had a problem when labeling at intervals using the “Evenly spaced” setting. It could corrupt the drawing if it 

encountered a zero-length polyline or a polyline that was shorter than the “Spacing value” setting. This has been 
fixed. 

 
6. The stand-alone CrossCheck command has benefitted from work done for CrossCheck in the beta version of the 

new AutoCAD MAPEDITOR. It now has a faster algorithm. If you are interested in advanced CrossCheck options, 
we encourage you to try the MAPEDITOR version (MapEd command).  
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7. A corrupted cursor value could cause the first point of a Capture tool to be off-screen. This was fixed. It is 
recommended that when first opening a drawing, to synchronize the SUMMIT EVOLUTION cursor with the 
AutoCAD cursor zoom in/out a little until the cursors are in the current views and moving together. 

 
8. DTMit has a new “sparse points” option. A grid is created by taking measured sample points and the vertices of 

the boundary object. Each point on the grid is interpolated using the closest measured sample points and/or 
boundary vertices. This is most effective if the boundary is of a uniform elevation and only the areas that have 
significant deviation are measured. To use this method, check on “Define Sample Points” in the DTMIT dialog. 
 

 
 

 Enable “Define Sample Points’ and define a layer to contain the measured sample points. Disable “Show 
Grid” and set the “Mark Settings” layer to the layer where you want the points to be placed. Select “Lock to 
Point”. The “Collect” button should be enabled. Click Collect and select one point inside each boundary 
object, making sure it is a point of elevation higher than the relative elevation of the boundary. 
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DAT/EM CAPTURE for MicroStation 

 
Changes apply to Capture for MicroStation V8/2004 Edition, MicroStation XM, and MicroStation V8i Series 1 or 2 on 32-bit and 
64-bit operating systems. Note: 

 MicroStation V8 and V8 2004 Edition: Version should be 08.05.00.34 or higher. 
 MicroStation XM and V8i Series 1: XM version should be 08.09.04.88 or higher. 
 MicroStation V8i, V8i-based Bentley Map and Map Enterprise Select Series 1 and Select Series 2: Select Series 2 is 

recommended over Series 1. 
o Note for Select Series 1-to-2 upgrades: If you upgrade Select Series 1 to Select Series 2, you must re-install any 

DAT/EM software to get the Select Series-2-specific DAT/EM applications.  
 

1. DAT/EM software can now install for Bentley Map Enterprise. 
 
2. 3DOFFSET has the following changes: 

a. It has been fixed to work in MicroStation V8i versions. 
b. It now saves and restores settings properly. 
c. An element that crosses (intersects) itself may not be used as input for 3DOFFSET. To help you see 

where self-intersecting elements were rejected by 3DOFFSET, there is a new Mark Failures option, 
which draws either a temporary or permanent square shape on the self-intersecting element. Use the 
Marker button to make settings for the marker. There are two key-ins to control marking: 

 3DOFFSET MARKON – sets the Mark Failures checkbox on without activating the dialog. 
 3DOFFSET MARKOFF– turns off Mark Failures without activating the dialog. 

  

 
3DOFFSET’s new Mark Failures setting 

 
2. The TOUCH command has the following changes: 

a. Interactive TOUCH was fixed to insert a vertex on complex elements. An exception is that if touching to an 
Arc sub-element (which is not formed of vertices), no vertex is added. In this case, convert the Arc to a string, 
B-spline or other object consisting of vertices before performing TOUCH. 

b. After running TOUCH from the parameter file, multiple lines were placed instead of adding a vertex. This was 
fixed. 
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3. An improvement was made that increases speed and prevents possible crashing in MicroStation XM and V8i 
versions. Any command that used a selection set editor or Callback could have been affected. Commands and 
functions that were directly affected are as follows: Check attributes, find duplicates, scop, si, capture, selection 
set editor, crosscheck, dtmdistributor, replace cell, mapstring, location control, EZ, eline, dtmedit, common (load 
time), change attributes, faceshift, datem menu, closestring, parameter file editor, zcheck, zlabel, labelit, gridit, 
and bmark. 

 
4. The MECLOSE dialog will now correctly make a new folder for the log file if the specified folder doesn’t exist. 

 
5. MapEditor parameter files that were made in version 6.2 or lower and contained a Replace Cell command were 

not compatible with version 6.3. This has been fixed so that they are compatible with version 6.4. 
 

6. ZLABEL has the following changes: 
a. The “Label evenly spaced Intervals” option with clipping on had a problem with restarting its spacing 

calculation based on the clipped line instead of the center of the previous text. Now it starts the spacing 
calculation from the previous text center, resulting in the same text spacing as with clipping off. 

b. When the “Label evenly spaced intervals” option was accidentally set so that the text element was longer than 
the interval distance, the message, “"Error: Text size exceeds interval” could repeat many times. Now it will 
appear only once and the labeling will stop. 

c. With the guiders option, in some cases the text could be placed at the elevation of the guider line. Now it is 
consistently placed at the elevation of the labeled polyline. 

d. Some types of elements cannot be used as templates for the “Same (Attributes) as labeled element” setting is 
on. If these types of elements are encountered, the labels will not be placed. Select specific attributes instead. 

 
7. MECLIP has the following changes: 

a. Bsplines are now allowed as exterior clipping boundaries. 
b. A new option, “Include Reference Elements as Boundaries”, allows boundaries to be found in reference files: 

 If checked, an extension to the Selection Set Editor allows the user to select reference elements (to 
extract symbology, etc.). 

 If checked, boundary elements will be found in the main file and all attachments. 
 If not checked, only those boundary elements located in the main file will be found. 
 Please note that since reference elements can never be edited, the to-be-clipped elements must be 

located in the main file. 
 

      
Interactive and MAPEDITOR parameter file Clip dialogs with new reference elements setting 
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8. METOUCH has the following changes: 
a. The interactive version of METOUCH may have caused the MicroStation window to flash or flicker when 

attempting to pick elements in MicroStation XM and V8i versions. This has been fixed. 
b. It now correctly inserts a vertex on complex elements when possible. Be aware that no vertex is added to an 

arc element, because arcs cannot have internal vertices. If a vertex is needed on arcs, convert the arcs to 
strings (Stroke Element MESTROKEELEMENT) before running METOUCH. 

 
9. DTMDISTRIBUTOR’s .sdtm (“Summit DTM”) output format was not being written correctly. This would cause 

problems when the file was subsequently used as input in other DAT/EM applications, such as SUMMIT EVOLUTION 

or LANDSCAPE. This has been fixed. 
 
10. CROSSCHECK has the following changes: 

a. Only processes each element once (speed improvement). 
b. Discards zero-length points (speed improvement). 
c. A memory deallocation problem was discovered and fixed. 
d. A potential problem processing complex elements as fragments has been fixed. 

 
11. MEXPORT is a new command similar to XYZOUT for exporting objects to a variety of file formats. It is available 

as a stand-alone key-in and from MapEditor parameter files. It allows export of elements into the familiar XYZOUT 
user-configurable formats, Visit files (for the VISIT command), and customer-requested legacy CaiCE formats 
ADF, SRV, and CEAL. 

 DAT/EM had very few example files of ADF, SRV, and CEAL. If you have any trouble with these 
formats, please send your example files to DAT/EM for further development. 

 If you would like to use this command, please ask DAT/EM for more detailed instructions. We will 
send you a separate document. 

 
Keyin: MEXPORT 
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Parameter File Tool: Choose “Export to File” from the “Command” menu in the Parameter File 
Editor. 
 

 
 
12. AUTOARC and AUTOARC2D previously made every element complex, even if the element contained only one 

simple line string or one arc. Now the element becomes complex only if it contains both an arc and a string or it 
has more than 5000 vertices. If a single arc is drawn, it will become a type 16 arc. If a single line string is drawn 
(with fewer than 5000 vertices), it will become a type 4 line string. 

 
13. A coordinate located outside of the current range of the model would cause VISIT to stop. This has been changed 

to alert the user that the coordinate will be skipped, and the cursor will not move until another point is selected 
that is within the model area. In future releases, model changes will be allowed. 

 
14. Several memory management issues were addressed. There should be fewer instances of crashing during 

DAT/EM CAPTURE and MAPEDITOR commands. This work particularly affects MicroStation XM, V8i, and V8i SS2 
versions. 

 
15. This change applies to all MAPEDITOR commands that can operate with reference files, such as JOINIT and 

MECLIP. When a command that supports reference files is open, it is now possible to pick objects in an attached 
reference file for level and attributes matching. This applies to the individual element picker, the object pick/match 
in Classes, and the object pick/match in the Selection Set Editor.  

 


